What am I working on?

Maverick, I did some work on this earlier in the year and created Far North QLD, North QLD, Central QLD and South East QLD, which might help you. I moved all the walks that were not in a sub-region (i.e. a NP etc) into these four regions using a rough latitude line. That didn’t actually take me that long to achieve.
As you said, the one thing not available at the moment is to move sub-regions into the seven regions suggested. Also currently ‘moderators’ can’t delete a region, probably as a safeguard, as it could be dangerous if there is a ‘walk’ within it, that might get deleted as well. I always as Richard to delete them.
Going forward, there is then a maintenance issue, as new bushwalk posters are notorious for not allocating walks to the correct region or sub-region, let alone providing the map co-ordinates! I try and keep an eye on new walks loaded, but not sure how to keep the dynamic accurate going forward?
O.K. that is QLD sorted, what about the rest? I did some work on Tasmania and more recently New Zealand, but I wouldn’t call it fully comprehensive.

Well I started as of yesterday, trying to get them more in line with a council region more so then a latitude line. I did notice some saying north QLD. But I’ve only changed them based on the point location.
Also noticed NZ, maybe it could be sub regioned North Island/south island? Haven’t really looked too much into other state regions. Might start a different forum tonight we’re different maps of regions can be stored for future reference.
Would be good if the point location decided the region it was located in, but that does seem like a lot of effort instead of just getting moderators to quickly look at the point location

1 Like

I split NZ into North and South region, but given there are so few walks, can’t see a good reason to introduce sub-regions.
South Australia should be easy; it only has six walks. And WA has only 10.

I’m loving the work here. I checked and moving subregions seems to be restricted to admins (aka me) at the moment so I’ll fix that up at the same time as I fix the walks. Shouldn’t take me too long.

I’ve been wanting to also write a little tool that will use state and national park boundaries to detect walks that aren’t in their correct region. That should help with these changes so I’ll pop that up the priority list.

1 Like

I had been thinking along those lines last night, of some how indication the boundaries of the regions/sub-regions on the ‘map page’, but reckoned it was probably a huge job for you to achieve. You have probably run out of colours to use! Users will not know the boundaries of the new seven sub-regions including myself.
This would definitely help when loading a new walk (and maintenance), as long as users look at the ‘map page’ first before adding a walk.
I have to say, that they don’t do a good job of this at the moment. If you look at the last two walks loaded (Piccabeen’ and ‘Pages’), they were both put in ‘Queensland’, but not in the sub-region of Conondale NP and Springbrook NP! (I will correct this later). This leads back to the discipline and maintenance issue I mentioned before. There are currently no ‘search’ options to identify them and you can’t keep going through 750+ QLD walks to make sure they are in the correct sub-region.
As a side note. The ‘Walk on water’ walk I mentioned the other day turned out to be a duplicate of an existing walk so I ‘merged’ it in order to get rid of it. Incidentally the ‘merge’ option does not seem to be working very well at the moment. It is very slow and does not pick up the walk you want to merge into correctly. I will write this issue up separately.

So shall I hold off checking/chaning the regions based off the map I had. I figured since it was based off council zones it may be a bit easier to indicate where it belongs if it’s not part of a national park.
Also I’ve added the council zones in each regions description, I know that wont help the people creating new walks, but might create some clarity if people are moving walks into the region/checking them.

Another Question. How many walks in a national park till you feel it’s worth creating a region for that national park? Or should all national parks be a region? If that’s the case, While I check tracks I can go about creating new regions for each too. Or would the thing you ( @AussieBushwalking) talking about highlighting the parks would this create regions that don’t exist?

Richard, as I mentioned above, ‘merge’ does not seem to be working so good.
Firstly, when you type in the name of the walk to want to merge into, is does not come up. As you type say three letters, it comes up with options, but only five. By some magic I got the right one to come up by backspacing a few times and retyping. But then when you press ‘search’ it takes ages for the details to come up.
The second small thing came to light since participating in the ‘forum’ lately. I changed my e-mail address on the front page ‘my profile’ a few weeks ago and that was fine and I now log in using it. But, within the ‘forum’ there is a ‘preferences’ profile, where the old e-mail is being shown and I am unable to edit it. I think the link between the two is not working.

Thanks Paul. I probably broke the merge with the map changes. I didn’t really test the moderator pages because I wanted to get the update out and there’s only a few of us that use them anyway.

I’ll look into the email change. That’s one I haven’t considered…

@F_A_B_Ferguson_Adven I’ve made a change that will have forced you to log off from the forum. Next time you’re here it should log you in again through the main site and that should update your email here in the forum.

There’s a chance it will create a new account for you. I’m pretty sure it won’t, but if it does let me know and I should be able to fix that up.

1 Like

Worked perfectly Richard. Thanks.

Richard, don’t seem to be able to load a photo at the minute. Tried on the laptop and phone and it does not want to load.
Please check it out. Thanks.

@F_A_B_Ferguson_Adven Could you email me the photo and which walk you’re trying to load it to so I can test with it? richard@aussiebushwalking.com

Thanks, Richard

1 Like

@F_A_B_Ferguson_Adven I’ve fixed that photo upload bug. Thanks for reporting it. That would’ve affected all the users. I’ve loaded that Mount Sefton photo you sent me as part of testing it so you’ll see that on https://www.aussiebushwalking.com/new-zealand/south-island-nz/kea-point now.

The same issue would have broken the GPS track upload as well so that should be working now.

1 Like

Always finding something for you Richard!
Mt Coochin, which I climbed for only the second time on Monday, has three GPS Tracks loaded on ‘walk detail page’, but nothing comes up on the ‘map page’. I downloaded all three onto my software and I think I can see why. Whilst I appreciate that your system will only load the first; that would be ‘Mt Coochin (reconstructed)’, this is one file with about five separate parts, that the system would not be able to handle and therefor ignore. The one called ‘original’ is not accurate and ‘loop’, is the correct one.
Is there some way you can delete all three and I will then reload ‘loop’? Thanks.

I’ve fixed that up. I have a page to help with this type of thing but it’s not quite ready for release to everybody. I can easily choose which file to use for the track though and delete some. You won’t need to reload the loop because I’ve already selected it.

1 Like

I’ve noticed that Mt Joyce summit walk’s region is currently listed as Main Range National Park and I know the moderators have been doing some work with the regions in Queensland. So if a moderator would be able to change the region for this walk as they are doing some of the others that would be great.

Also, the twelve apostles and twelve apostles overlook should be merged and the one photo on the twelve apostles overlook should be deleted as it has been misplaced. I’ll add some correct photos to the walk once they are merged.

Good spot Lahs. I have changed the region to South East Queensland.

Hi Richard. Need your help to delete a couple of ‘tracks’.
Both in Evans Head when I was tidying up the walk.
Snapper Point has a KML track, which I think is in fact a ‘route’ as it comes out as a straight line on the graph. If you can delete this, I can then load a correct one.
With Joggly Point, I mistakenly loaded an old un-adjusted track, that goes all over the place! Sorry. Please delete and I will then load the correct one.
Thanks.

Thanks Paul. I’ve removed those two routes. I can’t remember exactly how the graphs are updated but I think there will be a delay between when you upload the new file and when a new graph is generated (probably about 6 hours, but perhaps up to a day). Let me know if it doesn’t update the graph and I’ll look into it.

Richard, thanks for the deletes. Unfortunately there seems to be an issue, as although they have been deleted from the walks themselves, they still appear on the main ‘walks’ page map.
I don’t want to re-load till the old ones are gone, as this would be very confusing!